logo
Forgot login/password?

Forum

Go School Forum > Website & Forum > Stones missing from problems

Stones missing from problems


You must be logged in to post a reply. If you don't have an account, you can register.

2017-02-08 16:38
Enneit I've been having an issue a few times a day where a problem is missing a stone. On first load the problem seems to make no sense, but when I reload the page a new stone appears. So far one reload has always fixed the issue.

I've tried doing my problems in Chrome and Firefox in Linux (both up to date) and it happens in both.

As a side note, thank you for this wonderful site, I'm enjoying it despite this little headache. ^^

2017-02-08 18:28
Darrell Malick Hi Enneit,

Yes, we just found out about this bug. We're trying a fix now. Would you please let us know if you continue to see the bug please? Also, what device and what frequency?

Thanks!!

2017-02-08 21:44
Darrell Malick Sorry, never mind about my device question.

2017-02-09 15:26
pck In my case only one stone is missing when the problem occurs.
Latest Chrome and Safari on OSX both have this problem.
I don't see additional warnings in the javascript console when the error occurs.

For example in 1159_07.sgf and 1079_07a.sgf the "1" was still displayed but the stone is missing.
In 0976_01.sgf the pincering white stone was missing.
(Maybe it's always the last stone in the SGF?)

Bug frequency is about once per 300 loaded problems.



2017-02-09 16:52
Darrell Malick Thank you pck. I assume since you're posting it, that this bug is still active. Tricky one! (It's not the last stone in the sgf. Good idea tho)

2017-02-09 16:53
Darrell Malick EVERYONE: If you see this bug, please go to the *discussion* page for that problem and make a note there. Be sure to tell me exactly which stone was missing please.

2017-02-09 17:18
claude Knowing on which problem it happens and which stone is missing may help us...

2017-02-18 16:19
Darrell Malick If you run into this bug, please try clicking on the board at least once and then "Restart" the problem rather than reloading the page. Let me know if that puts the missing stone back on the board. Just click the "discuss" link and tell me there. Also, let me know if it was a computer or a tablet or phone that you saw it on. Thank you!

2017-02-21 01:43
pck It might be related to hovering the mouse on the board when the problem is loading. When the transparent stone moves away the field remains empty. It would explain why the issue doesn't affect mobile devices.

2017-02-22 07:04
rfmvad I think, I have the same problem. Sent an email to feedback@something with a screenshots.

2017-02-22 09:12
Darrell Malick Hi frmvad (and everyone),

Got your screen captures. Yes, a stone is missing from your problem. This is a tough and irritating problem that we've been putting a lot of effort into. We have an update we're testing now that I'm very hopeful will fix it.

For now, if you think you're missing a stone in a problem, any of these actions will normally restore it: refresh your browser, resize your browser window, or play a few stones and then click "Restart."

Fingers crossed that this update will solve the problem!

2017-03-06 06:56
rfmvad This issue appeared now in problem 1211_04b. The stone 3 is missing. There is only a number on the board, without the stone under it.

2017-03-07 15:17
quotient It's happened to me twice in the last week too (not to complain, just so you know that it's still an issue).

2017-03-07 15:27
Darrell Malick Thank you for letting me know. I'm sure my credibility is getting strained here, but I really do continue to believe we will have this fixed within another few days. Sorry for the bug!

2017-03-15 15:11
qianyilong Saw the missing stone and added it to the problem discussion.
https://internetgoschool.com/auth/discuss_problem.vhtml?pb_id=xVUxNtUl3tM$

I have screenshots as well if that is helpful.

Also this is on safari 10.0.2

2017-03-15 15:36
claude I just pushed into production a change that could fix the problem. If someone still see the problem, please tell me.

Post a reply