logo
Forgot login/password?

Forum

Go School Forum > Website & Forum > Technical problem

Technical problem


You must be logged in to post a reply. If you don't have an account, you can register.

2010-08-11 20:07
dkgnct I've just bought the year membership, but due to a technical problem I can't see the audio lectures in my laptop. I'm using the last version of ubuntu and the last version of java and mozilla firefox. When trying to see a lecture, I see the following error:
error:java.lang.ExceptionInInitializerError.
Any idea?

2010-08-11 22:19
claude Hi. This problem comes from the fact that the viewer doesn't currently work on the OpenJDK Java runtime environment - in the last version of Ubuntu, the Java environment defaults to OpenJDK, not to the Sun JRE.
To be able to view lessons, you must set up the Sun Java plugin, as follow:
$ sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"
$ sudo apt-get update
$ sudo apt-get install sun-java6-plugin
Then, you can activate the plugin with the command:
$ sudo update-alternatives --config mozilla-javaplugin.so
where you'll be presented with a list of all active Java plugins on the system and asked to choose the proper one, that is, the one located in /java-6-sun/.

Let us know if it works!



2010-08-12 01:04
dkgnct It worked, now it runs perfectly, thanks for your advice! That was indeed quick, effective and simple! Simply fantastic! Thank you very much!!!! :D

2010-08-28 13:21
Vicvain It works perfectly for me too.
Thanks !

Post a reply